Xiaomi Redmi 1S: TWRP error while updating from 5.8.28 to 5.9.16

I got the below error while updating from 5.8.28 to 5.9.16 by downloading OTA package from site.

E: error executing updater binary in zip

This error shows up in TWRP recovery in Xiaomi Redmi 1S.

Error screenshot:


Solution:

It is because of xcelerate kernel. Flash full stock ROM on existing ROM and all become default, now do OTA normally, later open Play store and download Super Su and open and update binary and flash TWRP recovery via Flashify or TWRP manager. And finally install Xcelerate kernel. This is the way I do whenever OTA comes, might be boring to do all the process, but the right way.

Alternatively, try flashing using CWM. This error seems specific to TWRP. 

Popular posts from this blog

Vivo Y51 themes download itz

Free games for 512 MB RAM Android mobile